Sécurité des fichiers PDF

Il est possible de chiffrer le contenu d’un document PDF ainsi que d’y ajouter des restrictions comme par exemple empêcher l’utilisateur de copier une partie du document par le presse-papiers ou même de ne pas autoriser l’impression du document !

Pour pouvoir tirer partie de ces fonctionnalités avancées, il est indispensable d’utiliser  AFPL GhostScript et aucune autre version (comme par exemple GNU GhostScript). De plus, il existe deux révisions du système de protections :

  • Révision 2 : Cette révision n'est pas utilisable avec AFPL GhostScript 8.14. Elle est utilisée avec des clés de chiffrement de 40 bits et produit des documents compatibles PDF 1.3, c'est-à-dire lisibles sous Adobe Acrobat 4.0 et supérieur ;
  • Révision 3 : Cette révision est capable d'utiliser des clés de longueur maximale de 128 bits et produit des documents compatibles PDF 1.4, c'est-à-dire lisibles sous Adobe Acrobat 5.0 et supérieur.

L’ajout de sécurité requière quelques paramètres supplémentaires à ps2pdf. Vous pouvez soit télécharger et utiliser le shell script  pdf_security.sh, soit l’un des formulaires ci-dessous pour générer les paramètres nécessaires.

ERROR: Content Element type "page_php_content_pi1" has no rendering definition!

Flattr